Journals, News

Atypon Literatum hosted sites will not be supported by Internet Explorer versions 8, 9 or 10 from 31 January 2018

How will this affect my access to LUP journals?

If you use these browser versions as an individual subscriber or have them set up on your internal institutional network, you will lose online access to the journals you subscribe to.

What can I do to prevent losing access to LUP journals?

Simply upgrade to Internet Explorer 11 or, install Google Chrome or Mozilla Firefox. You can do this free of charge by following the links below:

Internet Explorer >
Google Chrome >
Mozilla Firefox >

If you are unable to upgrade your browser by 31st January 2018 institutions can manually enable support for Internet Explorer versions 8, 9, and 10. However, this will only be offered as a temporary workaround until the network has been upgraded.

If you require further information or support, please contact us.